Accueil / Blog / Métier / 2013 / Howto install QGis with ECW Support on Linux

Howto install QGis with ECW Support on Linux

Par Gaël Pegliasco 22/10/2013
Recently I needed to install QGis using ECW support. This seems to never have been trivial due to ECW licence that is not free and not available on Linux distributions by default.

First, installing QGis
I have followed QGis developement version using QGis documentation for ubuntu via ubuntugis:

sudo apt-get install python-software-properties
sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable
sudo apt-get update
sudo apt-get install qgis python-qgis qgis-plugin-grass

Then download ECW
Go to and search for "ERDAS ECW/JP2 SDK Version 5.0 (Linux)"
Or directly download but this link seems needing that you answer the form above with your contact data before being used.

Then install ECW support on Linux:

chmod +x ERDAS_ECWJP2_SDK-5.0.bin
./ERDAS_ECWJP2_SDK-5.0.bin # Select option desktop read only
sudo cp -r ecwjp2_sdk /usr/local/
sudo ln -s /usr/local/ecwjp2_sdk/lib/x64/release/ /usr/local/lib/
sudo ldconfig
sudo apt-get install libgdal-ecw-src
sudo gdal-ecw-build /usr/local/ecwjp2_sdk
gdalinfo --formats | grep -i ecw

And run QGis (I had errors messages that I ignore), then, I was able to import ecw file using raster layer